This list of features becomes too long, and I’ve split it into several pages.

  1. Premium version
  2. Changelog
  3. General information (LEDs, pairing)
  4. Expert options
  5. Power saving mode or battery-powered devices
  6. Over-the-Air updates (OTA)
  7. RF signal level control
  8. GPIO inputs, outputs, and pull-ups
  9. Analog inputs (ADC), source voltage, an internal temperature
  10. UART
    UART sensor
  11. PWM
  12. LED firmware (WS2812B, Color control)
  13. Pulse generator and counter
  14. Group switch
  15. Pulse switch
  16. Bistable relay / Latching relay
  17. External sensors
  18. E18-MS1PA2, E18-MS1PA2-IPX, E18-2G4Z27SI or E18-TBH-28 Test board.
  19. E72-2g4m20s1e
  20. Serial bootloader on CC2652 or CC1352. Flashing firmware through a COM port.
  21. CC2531 configurable router
  22. DIY examples
Main window

Comments
Harvey Specter
Posted at 23:40 November 18, 2023
JohnRob
Reply
Author

I would like to send data both from external to host and host to external. The below from the Features page suggests text can only one way. I’ve tried a simple test with no success. I can send from external to host but not from host to external.
Is this still the situation? If it is, is there any plan for sending text in both directions?

Thanks
John

“The UART interface is designed to send text commands between an external device (e.g. Arduino) and a host. “

    Harvey Specter
    Posted at 09:30 November 19, 2023
    Owner
    Reply
    Author

    You can open an issue on GitHub and attach your settings, code or other info that can help to repeat this problem or suggest anything.

      Harvey Specter
      Posted at 19:18 November 19, 2023
      JohnRob
      Reply
      Author

      Thank you for your reply. Still leaves a question in my mind. I’m not sure what issue I should present in github.

      Is the current UART version expected to only go from external to Hub
      OR
      should it be able to go both from external to hub AND hub to external?

      Thanks
      John

Harvey Specter
Posted at 07:36 November 8, 2023
munther
Reply
Author

Hello pls i have question after i pay what will happen, do you need to remote my desktop to install or i can do it myself ? and if i format my pc can i download again on same pc or i will lose it forever, and thanks

    Harvey Specter
    Posted at 08:22 November 8, 2023
    Owner
    Reply
    Author

    You’ll receive a license code via email. The configuration program will ask you for this code when you save a firmware with premium features. You should do it yourself.

    You can download the program from this website anytime. But you should save the license code in a safe place.

Harvey Specter
Posted at 01:07 October 27, 2023
YONG LEE
Reply
Author

Hello,
I’m trying to pair it with the Smartthings station. I have two issues.

1) After flashing the firmware, the device is in the pairing mode as I can see the fast blinking LED.
But Smartthings can’t find and pair. it can be paired only when I press the P1 button for 10 seconds.
How can I pair with it while fast blinking without pressing 10 seconds?

2) pressing 10 seconds and then success the pairing. Now I can control ON and OFF from the Smartthings app. But after powering off and on my Zigbee device, can not control it anymore from the Smartthings app. to do that should re-pair the device by pressing 10 seconds.
Could you help me?

    Harvey Specter
    Posted at 03:29 October 27, 2023
    Owner
    Reply
    Author

    Sorry, but I do not Smartthings and cannot test the firmware with it.

      Harvey Specter
      Posted at 04:05 October 27, 2023
      YONG LEE
      Reply
      Author

      I understand. By the way, is it possible to request to custom version for smartthings with payment?

        Harvey Specter
        Posted at 09:34 October 28, 2023
        Owner
        Reply
        Author

        I cannot make a custom version without testing with a real hub on my side. But this hub is expensive, and I do not plan to invest in it.

    Harvey Specter
    Posted at 04:24 November 15, 2023
    JohnRob
    Reply
    Author

    FWIW I’ve used a number of CC2530 boards with the PTVO firmware and had no issues pairing with Hubitat Hub. I suggest you look at the power sequence to reset your board.

      Harvey Specter
      Posted at 00:17 November 16, 2023
      JohnRob
      Reply
      Author

      BTW I do not enable the 10 second paring feature on my devices.
      Last night I paired a CC2530 board connected to an SHT30 temperature sensor. After the required 3x 2 seconds on the device paired easily with my hub. It did however, take 40 to 50 seconds. I would think your smartThings hub would act the same.
      Once paired I can un power the CC2530 board and repower without having to repair.

Harvey Specter
Posted at 06:38 October 5, 2023
Daniel
Reply
Author

If I configure an input (wall switch) to toggle an output (light), what happens if my Zigbee coordinator crashes? Will I still be able to manually control the light from the wall switch?

Thanks!

    Harvey Specter
    Posted at 07:33 October 5, 2023
    Owner
    Reply
    Author

    In you mean a linked output on the same device, it will work without a coordinator.

Harvey Specter
Posted at 20:50 September 26, 2023
JohnRob
Reply
Author

Is there any though about adding ZAC wire as used by the iST5xx sensor? I’m guessing not as the usage is probably too low.

    Harvey Specter
    Posted at 07:32 October 5, 2023
    Owner
    Reply
    Author

    You can add the corresponding topic on Gihub for voting.

Harvey Specter
Posted at 01:39 August 8, 2023
AP
Reply
Author

Hello, trying to use latest edition of your system to work with ioBroker, Here is my configuration:
I configured P00-P02 as inputs, P003, P004 as analog inputs with max 3.3, and P10, P12 as digital outputs. Here are my issues:
1)IoBroker shows change of input only during input transition edge, I expected it to be input level driven
2) IoBroker shows analog inputs, P04 is working fine, P03 shows fixed value 0.224 but both inputs are electrically connected.
3) ioBroker does not show outputs, instead shows digital inputs.

What am I doing wrong?

Harvey Specter
Posted at 00:07 June 30, 2023
JohnRob
Reply
Author

I’ve been away from PVTO for a while. Today I downloaded v1.9.0.3 Has the SHT30 Temperature sensor been depreciated?
If so can I download the last version with the SHT30?

Many thanks
John

    Harvey Specter
    Posted at 03:18 June 30, 2023
    Owner
    Reply
    Author

    It was moved to a separate group: Temperature sensors I2C.

Harvey Specter
Posted at 14:25 March 25, 2023
greg
Reply
Author

do you have linux version of config?

    Harvey Specter
    Posted at 03:36 March 27, 2023
    Owner
    Reply
    Author

    Sorry, but no. But you can use it in the emulation mode or a virtual machine.

Harvey Specter
Posted at 19:54 March 14, 2023
Roland
Reply
Author

Hi, having a hand full of devices created using the SHTC3 temp and humidity sensor, I notice quite some ” noise” in the temperature readings. Wondering whether the SHTC3 driver uses the normal mode or the power safe mode as the latter has a significant lower repeatability.

BTW, self designed PCB using SHTC3, BMP280 and DS18B20 sensors all using PTVO. Working like a charm.

    Harvey Specter
    Posted at 04:06 March 15, 2023
    Owner
    Reply
    Author

    In the psm mode, the firmware executes a single shot measurement on the sensor. Maybe, it may affect repeatability.

Harvey Specter
Posted at 04:23 March 4, 2023
JohnRob
Reply
Author

Hi,
Your software is amazing. I’ve built some sensors for use with a Home Automation Hub, specifically a distance sensor. Works flawlessly.
This is a hobby for me. However if I was asked to build a few more of the distance sensor for some other Home Automation hobbyists what is the limitation for using your software (or the created HEX file)?
I find I sleep better at night if I’m sure I’m not doing something against the rules ๐Ÿ™‚
Thanks
John

    Harvey Specter
    Posted at 05:43 March 4, 2023
    Owner
    Reply
    Author

    Hi,
    You might add a note that the firmware is based on PTVO :), or promote it in your community. Finally, you may purchase a premium version. It stimulates me to support and improve the firmware.

Harvey Specter
Posted at 23:17 February 24, 2023
Pvl
Reply
Author

Hi. Pls, add HX711.

Harvey Specter
Posted at 07:52 January 6, 2023
Ernie
Reply
Author

How to configure the INA 219 (i2c) in Firmware Configurator?

Harvey Specter
Posted at 08:12 December 8, 2022
YONG LEE
Reply
Author

Hi,
Thanks for the great firmware for my testing purpose.
I’ve used the firmware for temperature reporting via UART communication between MCU and Zigbee module from EBYTE. It works well but after some hours,,, the Zigbee module stops working…??
The UART message is “{“action”:{“PipeNo”:0,”Temperature”:21.44},”linkquality”:109,”state_l1″:”OFF”}”
How can I solve this issue?
Should I use Premium version for stable operation?

    Harvey Specter
    Posted at 08:45 December 8, 2022
    Owner
    Reply
    Author

    You do not need the Premium version for your configuration. It is unclear to me why your module stops. Do you have a status led? Does it report anything?

      Harvey Specter
      Posted at 08:01 December 9, 2022
      YONG LEE
      Reply
      Author

      Yes, I have a flash button with LED and status LED as well.
      on normal operation status, press the flash button on the associated LED on/off toggle.
      status LED blinks at a minute interval.
      but at the stopped status non of the LED operation stops as well.
      what should I check for this?

        Harvey Specter
        Posted at 06:00 December 10, 2022
        Owner
        Reply
        Author

        Could you add the “Uptime” sensor to your device? It should increment, and it means that the device works correctly. In any case, I would prefer an opened issue on Github. It is more comfortable to discuss this problem.

Harvey Specter
Posted at 13:54 December 3, 2022
dimos
Reply
Author

Hi,
I am trying to create a reed switch (door sensor). I have added the sensor to p12 and GND and on software i configured Input 1 P12 GPIO Pull-up and Linked to out 1 checked.
All the other optios empty.
I have succeffully paired it but i cannot see the sensor status anywhere.
Am i missing something ?

Thanks
Dimos

Harvey Specter
Posted at 22:22 November 14, 2022
Anatoly
Reply
Author

Basic question from first time user. In you firmware configurator there are choices: router, end device without routing, 16 channels, PSM.

Will it work as router AND end device in router configuration?

    Harvey Specter
    Posted at 03:36 November 15, 2022
    Owner
    Reply
    Author

    The router firmware implements a router device. It cannot work as an end device. All other options work as an end device.

      Harvey Specter
      Posted at 01:17 November 16, 2022
      Anatoly
      Reply
      Author

      Thank you

      Harvey Specter
      Posted at 16:47 February 26, 2023
      Walt
      Reply
      Author

      neither in premium version? my folks would like that a lot

        Harvey Specter
        Posted at 03:42 February 27, 2023
        Owner
        Reply
        Author

        Some functions cannot live together in one device.

Harvey Specter
Posted at 13:40 November 14, 2022
Alex
Reply
Author

Thank you so much for your reply.
Is it possible to set a mathematical function that the analog input values can be adapted?

    Harvey Specter
    Posted at 03:34 November 15, 2022
    Owner
    Reply
    Author

    IMHO, math functions are out of scope of an IOT device. You can always make the necessary calculation at the higher level.

Harvey Specter
Posted at 11:28 November 14, 2022
Alex
Reply
Author

Thank you so much for your reply.
Is it also possible to add a mathematical function which changes analog input data in a certain way?

Harvey Specter
Posted at 10:55 November 14, 2022
Peter Molnar
Reply
Author

Dear PTVO,

I’d like to reprise a former question: support for a display.

I’ve been looking for a battery powered “thermostat” that would send an on/off signal when setpoint temperatures are reached, but this seems to be a rather rare thing. Most on the market are out of stock, and even when they are available, they are disturbingly pricy.

It’d need is a temperature sensor (although adding humidity and luminance would make it an even nicer device), a rotary encoder, and a small display, along with two internal variables ( either setpoint and hysteresis or low and a high setpoint) that can be changed locally or remotely via zigbee. It would need to run on battery power.

The display only needs to be on when the temperature changed, but an oldschool, non-lightened LCD can last years on battery, therefore it shouldn’t be a problem.

I’d be happy to help and/or pay for the existence of such an option within your firmware, if it’s a possibility.

    Harvey Specter
    Posted at 03:38 November 15, 2022
    Owner
    Reply
    Author

    It should be a fully separate device, as I did it for LED. Unfortunately, I don’t have too much time to do it.

Harvey Specter
Posted at 12:48 November 4, 2022
Alex
Reply
Author

I have a question about a cc2530 chip and analog input. First of all is it possible to use a PT100 sensor with an analog input? If it is possible will it work in PSM mode? Is it also possible to use this sensor with Z-Stack_3.0.x?

    Harvey Specter
    Posted at 14:03 November 4, 2022
    Owner
    Reply
    Author

    1. Sorry, but I don’t know this sensor.
    2. Analog input works in PSM.
    3. The firmware for CC2530 uses ZStack 1.2. If you need ZStack 3, you can use cc2652.

      Harvey Specter
      Posted at 22:29 November 14, 2022
      anatoly
      Reply
      Author

      Assuming PT100 is platinum resistance thermometer (PRT), I don’t think that you can connect it directly to analog input, you may want to build simple conditioning circuit (constant current source and differential amplifier) to convert out put into an acceptable voltage range.

        Harvey Specter
        Posted at 03:36 November 15, 2022
        Owner
        Reply
        Author

        Yes, correct.

Harvey Specter
Posted at 06:34 September 26, 2022
Roberto
Reply
Author

Hi, congratulation for the nice and useful work.
One question:
is the mt-interface supported, in particular in the router device-type? If yes, how can i enable it? That could be very useful for me.
My device is a Sonoff 3.0 USB Dongle Plus equipped with a CC2652P chip.
Thank you in advance for the clarifications.

    Harvey Specter
    Posted at 08:52 September 26, 2022
    Owner
    Reply
    Author

    No, the MT interface is not supported (it is excluded at all).

Harvey Specter
Posted at 15:14 August 19, 2022
dimos
Reply
Author

Hi,
Very nice job…..

Does it support reed switch ? for handling door open /close ?
If not , can you add support for reed switch also ? (For extra charge of-course)

Regards

    Harvey Specter
    Posted at 16:00 August 19, 2022
    Owner
    Reply
    Author

    Hi. Is is a simple GPIO input with pull-up, and yes, the firmware supports it.

Harvey Specter
Posted at 16:07 June 28, 2022
Gabriel
Reply
Author

Hi. Question about firmware features. Are the “devices” Bindable? ie: Using one device as Switch (On_OFF) to turn On/OFF another device as a Light? I was trying to do that using ZHA (on HA) capability but it didnยดt work. Is it a Premium Features or am I doing something wrong on

    Harvey Specter
    Posted at 16:14 June 28, 2022
    Owner
    Reply
    Author

    Yes, my firmware supports binding. It is the free feature.

Harvey Specter
Posted at 23:24 June 24, 2022
JohnRob
Reply
Author

Would you consider implementing the interface for a MAX31855? This is an I2C thermocouple interface.

Thanks
John

    Harvey Specter
    Posted at 03:59 June 25, 2022
    Owner
    Reply
    Author

    I am sorry but the firmware does not work with the SPI interface yet.

Harvey Specter
Posted at 10:26 June 23, 2022
Nirm
Reply
Author

I didn’t find a button to make a comment on page HLW8032. Is it disabled?

    Harvey Specter
    Posted at 04:05 June 25, 2022
    Owner
    Reply
    Author

    Thank you! I’ve enabled comments on that page too.

Harvey Specter
Posted at 04:45 April 28, 2022
JohnRob
Reply
Author

Just a simple note saying Thank you for your great utility/firmware. I used the UART capability on a CC2530 board. The Zigbee message is received by a Hubitat Hub. A simple driver was all that was needed to parse the UART message.
Works Great!
Thanks

    Harvey Specter
    Posted at 04:54 April 28, 2022
    Owner
    Reply
    Author

    Thank you! ๐Ÿ™‚

Harvey Specter
Posted at 05:00 April 7, 2022
JohnRob
Reply
Author

I have a simple configuration for a SHT30 temperature humidity sensor. See below:

I am receiving messages from this device every 1 second or so. I’m not sure where to start troubleshooting.

I don’t know if it helps but the raw message is: Raw Description#read attr – raw: 59A901000C265500391F85AF416F0018B71C004204432C3434, dni: 59A9, endpoint: 01, cluster: 000C, size: 26, attrId: 0055, encoding: 39, command: 0A, value: 1F85AF416F0018B71C004204432C3434

I’m using a Hubitat Hub which and worked great with a BME280 sensor with your firmware.

Any troubleshooting suggestions would be appreciated.

Thanks
John

Board type: CC2530
Device type: Router
Status LED: P12 (Inversed), Sending reports
Set default reporting interval (s): 60

Output pins:
P13: Output 1, SHT30 (I2C SDA), External pull-up (Address (dec): 68)
P14: Output 2, I2C SCL, External pull-up

    Harvey Specter
    Posted at 05:05 April 7, 2022
    Owner
    Reply
    Author

    Please try to enable the “Disable configuring the interval remotely” option on the Expert tab.

      Harvey Specter
      Posted at 22:11 April 8, 2022
      JohnRob
      Reply
      Author

      Hi, I tried checking “disable configuring the interval remotely” with the same bad results, Messages were coming at < 1 second intervals. I had been using V1.6.2.3.

      I then tried V1.6.0.2 and the responses were correct. Messages at 60 second intervals.

      Also, the Zigbee parsing was more complete on the v1.6.0.2 message making me think the message structure was different.

      I'm good for now. However I can give you additional information if you want to do further investigation.
      BTW the version numbers quoted are from Windows … file/properities/details.
      BR
      John

        Harvey Specter
        Posted at 05:28 April 10, 2022
        Owner
        Reply
        Author

        Could you please add your issue on GitHub and add screenshots with your configuration and additional information that I can check on my side?

Harvey Specter
Posted at 21:13 March 20, 2022
Nobodyman
Reply
Author

Could you please explain which Zigbee stack version your software supports if using CC2530 device.
Thank you very much!

    Harvey Specter
    Posted at 03:35 March 21, 2022
    Owner
    Reply
    Author

    ZStack 1.2

Harvey Specter
Posted at 22:12 March 19, 2022
JohnRob
Reply
Author

Have you had any thoughts about adding support for an I2C display? Or perhaps an I2C “repeater”, although I’m not sure how this would work.
Thanks
John

    Harvey Specter
    Posted at 09:02 March 20, 2022
    Owner
    Reply
    Author

    I didn’t plan to add support for displays because it is a universal solution.

Harvey Specter
Posted at 16:05 February 11, 2022
Giovanni
Reply
Author

Hi, do you think it would be possible to add Wiegand support to your firmware? It would be very useful to build zigbee Wiegand id tag readers

    Harvey Specter
    Posted at 05:16 February 14, 2022
    Owner
    Reply
    Author

    Hi, sorry I didn’t plan to add the Wiegand interface.

Harvey Specter
Posted at 10:38 January 20, 2022
Ken
Reply
Author

Hi
Is it possible to configure a dimmer switch, so the device model is a ptvo.dimmer?

Reason for asking, is that a controller is identifying the device type and assigning correct device handler / driver setup for the device.

    Harvey Specter
    Posted at 11:02 January 20, 2022
    Owner
    Reply
    Author

    Yes, you can specify any model ID.

      Harvey Specter
      Posted at 12:10 January 20, 2022
      Ken
      Reply
      Author

      Do you have any examples for dimmer configuration?

        Harvey Specter
        Posted at 12:15 January 20, 2022
        Owner
        Reply
        Author

        It depends on your hardware. Usually, it is the PWM output.

          Harvey Specter
          Posted at 15:22 January 20, 2022
          Ken
          Author

          So if you have a zigbee dimmer, where 2 inputs are connected to buttons for up and down, and an PWM output for controlling the light.
          Long press on up increase value, short click go too maximum.
          Long press on down decrease value, short click turn out light (go to minimum).
          Do you have a configuration example for that ๐Ÿ™‚

          Harvey Specter
          Posted at 03:32 January 21, 2022
          Owner
          Author

          You can link only one button to an output. The button will change the light level circularly.

Harvey Specter
Posted at 03:19 January 14, 2022
Ilya Rakhlin
Reply
Author

Do you happen to have any experience or examples of getting any builds of your firmware working in ZHA (home assistant ZHA). All is working well with the z2m converter but I have a few friends I was hoping to use for beta testing a device who are on ZHA. I’ve previously written a few z2m converters but have very little experience with ZHA quirks. As I start to play around with it I just wanted to see if you had any examples or samples I could use as a jumping off point. Would be especially helpful if it uses the TemperatureMeasurementCluster or Humidity.

Thank you

    Harvey Specter
    Posted at 04:34 January 14, 2022
    Owner
    Reply
    Author

    Sorry, but I don’t have examples for ZHA.

Harvey Specter
Posted at 18:49 January 8, 2022
Tube
Reply
Author

What are the child and route table sizes for the cc2652?

    Harvey Specter
    Posted at 03:48 January 10, 2022
    Owner
    Reply
    Author

    The child table was compiled with the following key value:
    MAX_DEVICE_TABLE_ENTRIES=50

Harvey Specter
Posted at 01:29 January 7, 2022
Philip
Reply
Author

Hello any chance to integrate HX711 Load Cell Amplifier to sensor list?

    Harvey Specter
    Posted at 07:33 January 7, 2022
    Owner
    Reply
    Author

    Hello, Sorry, but I didn’t plan to add this sensor.

Harvey Specter
Posted at 23:28 December 18, 2021
Ilya Rakhlin
Reply
Author

Just curious about sensor compatibility, I understand you may not have tested these but do you know if there are any reasons why the HDC2XXX line of sensors would work (https://www.ti.com/product/HDC1080 listed under similar on this page). According to a TI forum post they are firmware identical, https://e2e.ti.com/support/sensors-group/sensors/f/sensors-forum/861532/hdc2010-technical-differences-among-hdc2080-hdc2010-hdc1080

In that same line of questions, SHT30 is listed as supported, it would seem the SHT31 and SHT35 are also firmware identical and differences are around accuracy, voltage, ect. I understand they may not be tested but is there any reason they would not work? With the current shortage of parts sometimes it easier to be flexible.

Harvey Specter
Posted at 06:27 December 17, 2021
Paul
Reply
Author

Description of Zigbee2MQTT-Commands need a note on the required Zigbee2MQTT version. In Zigbee2MQTT 1.17.0 a new API was introduced. Using the format of the current documented commands will not work with Zigbee2MQTT versions >1.16. It would be helpful to get a hint about this circumstance.

    Harvey Specter
    Posted at 07:07 December 17, 2021
    Owner
    Reply
    Author

    I use v1.18 and these commands work. Could you please describe the format in your case?

      Harvey Specter
      Posted at 15:36 December 17, 2021
      Paul
      Reply
      Author

      The following zigbee2mqtt command is working fine in version 1.12.
      -t zigbee2mqtt/garage/l3/set -m {\”trigger\”:800}
      after upgrading to version 1.22. it’s no longer working. I played a bit with the new command syntax e.q -t zigbee2mqtt/garage/set -m {\”state_l3\”:800} but without success. So what is the correct format to initiate a trigger?

Harvey Specter
Posted at 00:57 August 7, 2021
Shonn
Reply
Author

The problem report:
I have an old power plug with a cc2530(external 32.00MHZ oscillator) and FM24C02C eeprom. Sometimes the plug cannot boot, the led keep the dim light state(the normal state is off or light).
I try to fix this problem with the configure of cc2530(without oscillator).

« Older Comments

Leave a Reply to Alex
Cancel Reply