First of all, you must specify a pin for a sensor. It is the SDA pin. Then it would help if you defined the SCL pin. For example, output 4 – BME280, and output 5 – I2C SCL.

I2C configuration for a sensor

If you connect several sensors on one bus (pin), you may define the SCL pin only once.

This image has an empty alt attribute; its file name is img1-4.png
I2C configuration for sensors on one bus

Zigbee: Accepts the “read” and “write” commands on the endpoint for the SDA pin.


Comments
Harvey Specter
Posted at 19:25 December 20, 2021
Frithjof
Reply
Author

how do I request an I2C sensor reading? I tried

zigbee2mqtt/0x00124b001caab995/l7/get/temperature

and got

z2m message zigbee2mqtt/bridge/logging {“level”:”error”,”message”:”No converter available for ‘temperature’ ()”}

    Harvey Specter
    Posted at 04:51 December 22, 2021
    Owner
    Reply
    Author

    The firmware supports the read command for GPIO outputs and ADC inputs only.

Harvey Specter
Posted at 13:52 December 18, 2021
Frithjof
Reply
Author

Hi, I connected a BH1750 module. Anyway I don’t get any readings.
I connected a logic analyzer and found that the firmware does not query the device.

Is BH1750 a pro feature?

One more thing I noticed, if a BMP280 is configured, the firmware queries device 0x7b in the first place. This is actually a PCA9685. It writes a byte to that device and then continues with 0x76, the actual BME280.

    Harvey Specter
    Posted at 06:52 December 19, 2021
    Owner
    Reply
    Author

    I cannot answer to your question precisely because I do not see your settings.

      Harvey Specter
      Posted at 08:21 December 19, 2021
      Frithjof
      Reply
      Author

      Here’s the settings:
      Board type: CC2652R1
      Device type: Router
      Update firmware’s timestamp : 2021-12-18
      Status LED: P11, Periodic (every 5 seconds)
      Set default reporting interval (s): 60

      Output pins:
      P06: Output 1, PWM (Hardware, 128 kHz), External pull-up (Frequency: 1 kHz, Transition time (ms): 0, Linked input: Changes level)
      P07: Output 2, PWM (Hardware, 128 kHz), External pull-up (Frequency: 1 kHz, Transition time (ms): 0, Linked input: Changes level)
      P08: Output 3, GPIO, External pull-up
      P09: Output 4, GPIO, External pull-up
      P05: Output 5, BMP280 (I2C SDA), External pull-up (Address (dec): 119)
      P04: Output 6, I2C SCL, External pull-up
      P05: Output 7, BH1750, External pull-up (Address (dec): 35, Resolution: 1 lux)
      P02: Output 8, UART (Baud rate: 9600, Packet end: 0x0D, Byte: 239)

      Input pins:
      P15: Input 1, GPIO, Pull-up, Long, Double, Tripple
      P12: Input 2, GPIO, Pull-up
      P30: Input 3, ADC (max 3.3V)
      P49: Input 4, Source voltage
      P13: Input 5, GPIO, Pull-up
      P14: Input 6, GPIO, Pull-up

        Harvey Specter
        Posted at 11:34 December 31, 2021
        Frithjof
        Reply
        Author

        December Release (2021-12-30) makes it work!
        This config results in both weather and illuminance reports:
        P05: Output 6, BMP280 (I2C SDA), External pull-up (Address (dec): 118)
        P04: Output 7, I2C SCL, External pull-up
        P05: Output 8, BH1750, External pull-up (Address (dec): 35, Resolution: 1 lux)

Harvey Specter
Posted at 12:36 November 7, 2021
Gus
Reply
Author

Hello, does the firmware support i2c for Pn532 RFID/NFC ?
Thank you

    Harvey Specter
    Posted at 10:59 November 10, 2021
    Owner
    Reply
    Author

    No, the firmware does not support this sensor.

Harvey Specter
Posted at 20:20 May 17, 2021
Pavel
Reply
Author

Hello, does the firmware support i2c expander like VL53L0X ? Thank you.

    Harvey Specter
    Posted at 04:32 May 18, 2021
    Owner
    Reply
    Author

    No, the firmware does not support this sensor.

Harvey Specter
Posted at 15:49 February 8, 2021
marac
Reply
Author

Hello, does the firmware support i2c expander like MCP23017? Thank you.

    Harvey Specter
    Posted at 03:37 February 9, 2021
    Owner
    Reply
    Author

    Hello. The firmware does not support this expander.

Harvey Specter
Posted at 19:54 December 14, 2020
Rozenrod
Reply
Author

I connected BME280, P05-> SCL, P06-> SDA address 76 (verified through arduino), But Zigbee2MQTT does not receive temperature data, etc., I only get “payload ‘{” l3 “: 3.2,” linkquality ” : 84, “voltage_l3”: 3.2} ‘”What should I do, am I doing something wrong?

    Harvey Specter
    Posted at 03:28 December 15, 2020
    Owner
    Reply
    Author

    Did you define the SDA pin first? For example, SDA – output1, SCL – output2.

      Harvey Specter
      Posted at 20:08 December 15, 2020
      Doublet
      Reply
      Author

      I observed the same behaviour with BME280 on a CC2530
      Output p04: SDA, p05: SCL, router mode
      Payload: {“l1″:3.45,”l2″:56,”linkquality”:113,”temperature_l2″:56,”voltage_l1″:3.5}

        Harvey Specter
        Posted at 20:32 December 15, 2020
        Doublet
        Reply
        Author

        Further testing CC2530 BME280:
        When I use P06: SDA, P07: SCL or P10: SDA, P11 SCL and try to pair in Z2M:
        the device is announced, the led is flashing each 4 seconds but no data or even linkquality is visible in MQTT? Any suggestions?

Harvey Specter
Posted at 07:55 December 11, 2020
Doublet
Reply
Author

I am using https://nl.aliexpress.com/item/32659765502.html?spm=a2g0s.9042311.0.0.27424c4dF0Pr06
The status light is flashing short, fast blinks every second

    Harvey Specter
    Posted at 08:08 December 11, 2020
    Owner
    Reply
    Author

    I think the problem is not related to the sensor. Just wait more time or try to reset the device.

Harvey Specter
Posted at 19:55 December 10, 2020
Doublet
Reply
Author

When I configure the CC2530 as in your example with a BMP280, the device does not want to pair (not in router or in end device mode). When I choose another configuration MHZ90, DS18B20 all works fine. I a using your recent software. Can you pls check while you enjoy a cup of coffee?

    Harvey Specter
    Posted at 03:43 December 11, 2020
    Owner
    Reply
    Author

    Thank you! I like coffee :).
    Did you test with BMP280 or BME280? Does the status light show somethings? I cannot repeat this problem with BME280.

Leave a Reply to Doublet
Cancel Reply